PayPal Cash Out Issues
Incident Report for The Creator Marketplace
Resolved
We have identified an interim solution for creator payment.
Posted Apr 15, 2021 - 14:36 EDT
Update
We are continuing to investigate this issue with PayPal. An ETA remains unknown at this time. We will continue to post updates as we have them.
Posted Apr 15, 2021 - 08:17 EDT
Identified
We are continuing to investigate the issue and are in contact with PayPal. We have identified the root cause, and are working on a solution but do not have an ETA at this time.
Posted Apr 14, 2021 - 16:30 EDT
Investigating
We are aware of issues when attempting to cash out to PayPal and are actively investigating.
Posted Apr 14, 2021 - 13:54 EDT